Kuidas vormindada numbreid M-ks või miljoniks

Suured numbrid ümardatakse sageli miljoniteks või lihtsalt numbriks, millel on täht 'M' või sõna 'miljon'. Näiteks 4 569 885 on 4,57 miljonit või 4,57 miljonit. Palun kontrollige kuidas vormindada telje silte miljonitena kui töötate diagrammiga.

1. M lisamiseks

Kui soovite muuta suure arvu numbriks 'Arv + M', võite kasutada allolevat valemit.



=TEKST(A2,'#.00,, \M')

Kus '#.00' tähendab, et tulemus jääb kahekohaliseks.

Valem on teisendada arv miljoniks, lisades lõppu tähe 'M' vastavalt üldisele ümardamisreeglile. Kui sajatuhandeline number on 5 või suurem, ümardatakse arv üles ja kui saja tuhande number on väiksem kui 5, ümardatakse arv alla.

2. Kombineerige 'Million' või 'M'

Teine võimalus on ümardada suured arvud esmalt lähima miljonini, seejärel ühendada teosega 'Miljon' CONCAT funktsioon alloleva valemiga.

=TEKST(A2/1000000,'#,###,###.##')&'miljon'

või muuta 'Miljon' väärtuseks 'M' järgmise valemiga.

=TEKST(A2/1000000,'#,###,###.##')&'M'

Pange tähele, et kui arv on väike, ümardatakse arv ja tulemuseks on '.Miljon'. Selle olukorra vältimiseks kasutage palun IF funktsioon selle tingimiseks. Näiteks kui soovite säilitada 2 numbrit, ümardatakse 5000 0,01 miljoniks. Arve, mis on väiksemad kui 5000, ignoreeritakse.

Kui töötate Excel 2016 või vanema versiooniga, saate kasutada funktsiooni IF järgmiselt.

=IF(A2<5000,'',IF(A2>=5000,TEKST(A2/1000000,'#,###.##')&'M'))

Kui töötate Excel 2019 ja uuemaga, saate kasutada IFS-i funktsiooni järgmiselt.

=IFS(A2<5000','A2>=5000,TEKST(A2/1000000,'#,###.##')&'M')