Kuidas saada valemi järgi loendis 3 parimat üksust

Kui töötate andmetega otse, saate sortida veeru alusel ja seejärel hõlpsasti hankida parimad väärtused. Näiteks, sortida väärtus suurimast väikseimani 3 parima väärtuse otsustamiseks, seejärel hankige väärtustel põhinevad üksused.

Kui aga töötate koos Pivot tabel mis sisaldab palju kogukondi, on 3 parima väärtuse leidmine keeruline, kuna väärtus muutub erinevates kogukondades.

Maksimaalse väärtuse saamiseks:



=INDEKS(A2:A6, MATCH(MAX(B2:B6),B2:B6,0))

Suuruselt teise väärtuse saamiseks:

=INDEKS(A2:A6, MATCH(SUUR(B2:B6, 2),B2:B6,0))

Suuruselt kolmanda väärtuse saamiseks:

=INDEKS(A2:A6, MATCH(SUUR(B2:B6, 3),B2:B6,0))